This is an old revision of the document!


Requirements

Below are the minimum and necessary requirements for the applications and tools to be used for the Mobilize project in 2013. Please refer to these to ensure that your lab and/or devices are able to run the necessary tools. If you have questions but they don't seem to be covered here, please contact us.

There are two main software tools used in the Mobilize projects:

  1. Mobilize software suite for data collection and visualization.
  2. RStudio for hands-on data analysis.

1 Mobilize software suite

1.1 Mobilize Web Browser Requirements

The Mobilize Web Frontend is a customization of the ohmage web frontend. It supports the following common browsers.

  • Chrome
  • Firefox (latest 3 versions only).
  • Safari (versions 4+)
  • Internet Explorer, only when using the Chrome Frame plugin

1.2 Mobilize Mobile App Requirements

The Mobilize mobile apps are mainly used for data collection. The apps are available on the Android and IOS smartphones:

Android App

The Mobilize Android phone app supports many Android devices and device types. The app requires the following Android version:

  • Android 2.2 and newer. Visit your settings menu, scroll to “About phone” or “About device” to determine your model's current Android version.
  • ECS Students/Teachers looking to ease the discover of supported Android devices can visit this page from the mobile device to have support automatically detected.
Apple iOS App

The Mobilize IOS app supports the following Apple iOS devices and models:

  • iPhone (3gs, 4, 4s, 5 and newer are supported)
  • iPod touch (3rd, 4th, 5th genrations and newer)
  • iPad (iPad 2, 3rd generation, 4th generation and newer)
  • iPad mini
  • ECS Students/Teachers looking to ease the discover of supported iOS devices can visit this page from the mobile device to have support automatically detected.

2 RStudio Web Browser Requirements

RStudio is an external, open-source project. While they have very liberal browser requirements, below is a list of those they recommend on this page

  • Firefox 3.5
  • Safari 4.0
  • Google Chrome 5.0
  • Internet Explorer (when using the Chrome Frame plugin)
Print/export